6-25
Cisco MDS 9000 Family NX-OS Interfaces Configuration Guide
OL-29284-01, Release 6.x
Chapter 6 Configuring PortChannels
Configuration Examples for F and TF PortChannels
switch(config)# interface fc2/1-3
switch(config-if)# shut
switch(config-if)# switchport mode NP
switch(config-if)# switchport speed 4000
switch(config-if)# switchport rate-mode shared
switch(config-if)# switchport trunk mode off
switch(config-if)# channel-group 1
switch(config-if)# no shut
switch(config-if)# exit
Step 7 Set the administrative state of all the PortChannel member interfaces in both NPIV core switch and the
NPV switch to ON:
switch(config)# interface fc1/1-3
switch(config-if)# shut
switch(config-if)# no shut
switch(config)# interface fc2/1-3
switch(config-if)# shut
switch(config-if)# no shut
Note The speed configuration must be the same for all member interfaces in a PortChannel. While configuring
the channel in dedicated mode, ensure that required bandwidth is available to the ports.
This example shows how to configure channeling in dedicated mode and bring up the TF-TNP
PortChannel link between TF ports in the NPIV core switch, and TNP ports in the NPV switch:
Step 1 Enable the F port trunking and channeling protocol on the MDS core switch:
switch(config)# feature fport-channel-trunk
Step 2 Enable NPIV on the MDS core switch:
switch(config)# feature npiv
Step 3 Create the PortChannel on the MDS core switch:
switch(config)# interface port-channel 2
switch(config-if)# switchport mode F
switch(config-if)# switchport rate-mode dedicated
switch(config-if)# channel mode active
switch(config-if)# exit
Step 4 Configure the PortChannel member interfaces on the MDS core switch in dedicated mode:
switch(config)# interface fc1/4-6
switch(config-if)# shut
switch(config-if)# switchport mode F
switch(config-if)# switchport speed 4000
switch(config-if)# switchport rate-mode dedicated
switch(config-if)# switchport trunk mode on
switch(config-if)# channel-group 2
switch(config-if)# no shut
switch(config-if)# exit
Step 5 Create the PortChannel in dedicated mode on the NPV switch:
switch(config)# interface port-channel 2
switch(config-if)# switchport rate-mode dedicated